Back to overview
Downtime

Status report title

Jun 26 at 03:33pm CEST
Affected services
wp.pnc365.eu

Resolved
Jun 26 at 03:35pm CEST

Incident solved

Updated
Jun 26 at 03:34pm CEST

Just a test - safely ignore

Created
Jun 26 at 03:33pm CEST

Status update message